Erreur de compilation

Page 3 sur 3 Précédent  1, 2, 3

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: Erreur de compilation

Message par pbrn le Mar 23 Aoû - 10:23

Salut,
Non, il n'est pas identique à mon user_config.py

Si tu compare ta ligne et celle de mon fichier, tu verras que tu n'a pas respecté les espaces !

Dailleurs, c'est ce qu'il te dit : Il te renvoie la ligne fautive et il te dit que l'indentation n'est pas bonne. Donc, il ne peut pas reconnaître la commande.

Le premier réflexe, c'est de comparer la ligne de ton fichier avec l'original.
Les espaces dans les commandes sont aussi importants que les caractères pour que la commande puisse être interprétée. Une autre chose aussi, crée ton fichier dans gedit, vim... mais pas dans un traitement de texte. Il faut du texte pur !

Bon, si tu n'arrive pas à recopier ces lignes correctement, je peux t'envoyer mon user_config.py et tu n'auras qu'à le mettre dans le répertoire Blender de tes fichiers SVN.. Rolling Eyes

Pour répondre à ta précédente question :
Si on est obligé d'installer cette nouvelle librairie de développement, c'est parce que la fonction NDOF a été intégrée (la souris 3D).
Comment on peut savoir sans trop rentrer dans les détails, quand on compile et qu'une erreur apparaît, le compilateur nous renseigne sur cette erreur et le langage C et C++ sont des langages très structurés. Les noms des modules et headers portent un nom qui permet de retrouver. Il suffit d'ouvrir ces fichiers pour voir ou ça coince et ce qu'il a appelé. On appelle ça le débogage.

Les librairies xxxx-dev sont des librairies de développement ou au moment du linking des fichiers modules compilés, le compilateur va chercher les infos nécessaires. Ces librairies ne servent que pour la compilation.

Donc, oui ça marchait avant, mais Blender évolue comme tout programme et il faut ajouter ce qu'il manque !! Wink


_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2287
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par gilouni le Mar 23 Aoû - 15:22

Salut pbrn

Ok,ça marche.Mais dans un premier temps je n'ai pas vu une différence d'espace entre le premier et le deuxième.Ce n'est qu'au bout d'un moment que j'ai remarqué que dans le premier il y avait une marge pour toutes les lignes alors que dans l'autre ,non.
Moi je regardais les espaces entre les signes et les lettres;c'est pourquoi je ne comprenais pas. A+
avatar
gilouni

Messages : 50
Date d'inscription : 11/03/2011
Localisation : Nice

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par pbrn le Mar 23 Aoû - 17:58

re,
Evil or Very Mad Non, Non !
Il n'y a pas de marges !
Chaque ligne commence à gauche et elles sont toutes au même niveau !
L'erreur que tu avais c'est que par exemple ; entre un mot clé et le signe =, tu n'avais pas d'espace. L'espace sert à dire que le mot s'arrête là.
C'est logique pour qu'il puisse le reconnaître !
De même si tu as remarqué qu'il y a aussi des underscores pour les mots clés composés.
N'oublie pas que c'est mots clés sont définis et il doivent absolument être bien écrits et formatés. Même un caractère majuscule est différent de sa minuscule.
Les apostrophes sont aussi importants.

La prochaine fois ou il y aura des modifs importantes et il y en aura un jour. Si tu n'est pas sûr, demande avant.

Autre chose, bientôt la 11.10 va sortir, ne te précipite pas pour l'installer, le temps que tout soit OK si tu veux compiler.. Wink

L'important, c'est que tu ais réussi ! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2287
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par gilouni le Jeu 31 Mai - 7:41

Salut à tous

Depuis quelques temps,il y a des problêmes d'erreurs d'authentification lorsque l'on veut compiler blender.Il paraitrait que cela apparait sur les distrib à base debian : donc ubuntu,linux mint que j'ai adopté et bien evidemment debian.Quelqu'un saurait-il comment contourner le problème? . Je suis bien allé sur des forums,notamment le blender clan,mais les réponses ne sont pas assez précises.Merci
avatar
gilouni

Messages : 50
Date d'inscription : 11/03/2011
Localisation : Nice

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par pbrn le Jeu 31 Mai - 10:18

Salut,
Le problème, c'est que si tu veux compiler avec scons, tu auras des problèmes.
Il y a deux environnements scons et make. Installe Make !
Il faut utiliser Make qui est plus élaboré ! C'est avec Make que les versions officielles sont compilées ! Pour scons, il n'ont peut être pas eu le temps de tout réadapter ! Bien que c'est le compilateur gcc++ qui est utiliser dans les deux cas ! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2287
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par gilouni le Jeu 31 Mai - 12:40

Merci pour ta réponse pbrn,je vais installer make et voir si ça marche.
avatar
gilouni

Messages : 50
Date d'inscription : 11/03/2011
Localisation : Nice

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par pbrn le Jeu 31 Mai - 13:04

Salut,
Suis cette procédure
Tu auras sûrement des libray à installer ! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2287
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par gilouni le Jeu 31 Mai - 16:20

C'est en effet la procédure que je suis.Seulement,lorsque je télécharge les sources,ça bloque.
Voilà ce que j'obtiens:

gilouni@Ares-Gilles ~ $ cd blender-svn
gilouni@Ares-Gilles ~/blender-svn $ svn co https://svn.blender.org/svnroot/bf-blender/trunk/blender
svn: OPTIONS de 'https://svn.blender.org/svnroot/bf-blender/trunk/blender': Erreur de vérification du certificat: signed using insecure algorithm (https://svn.blender.org)
gilouni@Ares-Gilles ~/blender-svn $ .

D'après ce que j'ai pu lire sur certains forums,ils auraient supprimé les listes d'organismes chargés de vérifier les certificats,ce qui donnerait cette erreur. Une des solutions serait de trouver un certificat valable; mais où le trouver et comment l'installer.

avatar
gilouni

Messages : 50
Date d'inscription : 11/03/2011
Localisation : Nice

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par pbrn le Ven 1 Juin - 10:38

Salut,
Je les télécharges sans problèmes ! Rolling Eyes
Regarde si les permission sont OK dans le répertoire !
Sinon, supprime tous les fichiers du répertoire SVN sur ton disque et télécharge-les à nouveau !
Suis la procédure indiquée sur le Wiki ! Il y a peut-être longtemps que tu ne les as pas téléchargé.. Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2287
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Erreur de compilation

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 3 sur 3 Précédent  1, 2, 3

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum