Comment compiler Blender 2.5 sur Ubuntu

Voir le sujet précédent Voir le sujet suivant Aller en bas

Comment compiler Blender 2.5 sur Ubuntu

Message par Admin le Lun 17 Mai - 14:27

Bonjour,
Certains ont quelques difficultés à compiler les dernières versions de Blender 2.5 suite aux dernières évolutions.
Blender 2.5 utilise Python 3.1, FFMPEG et tout un tas de dépendances qu'il faut installer !

Je viens de refaire un tutoriel sur la procédure pour compiler avec scons. Mise à jour le 14/07/2010 suite à des problèmes rencontrés par certains : Comment corriger une erreur à la compilation et récupérer les fichiers manquants !
Vous pouvez voir ce tutoriel au format pdf

Si vous avez quelques difficultés, j'ai mis aussi mon fichier tarball à disposition de la version r33096
Compilation du 16/11/2010 (nouvelle version Blender 2.55 Beta)

ça évolue et ça avance à grands pas !

Si vous avez des questions, n'hésitez pas à les poser !
Wink
avatar
Admin
Admin

Messages : 147
Date d'inscription : 22/04/2010
Localisation : Cognac, Charente

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par Admin le Dim 19 Déc - 14:02

Bonjour à tous,
Comme on le sait, le processeurs récents sont tous en 64 bits aujourd'hui !
Donc pourquoi ne pas utiliser toute la puissance de nos processeurs ?
La première condition, c'est d'avoir installé un OS 64 bits pour pouvoir utiliser toute la puissance des processeurs modernes !
Dans la modélisation 3d, ça devient incontournable d'utiliser un OS 64 bits !
Utiliser un OS 32 bits avec un processeur 64 bits, c'est purement du gâchis de performances ! Crying or Very sad
Donc aujourd'hui utilisons toutes les performance de nos processeurs !
Donc, maintenant je vous propose d'utiliser les versions de Blender compilées pour Ubuntu 64 bits !
Je vous propose aussi un tutoriel pour compiler Blender en 64 bits :



Si vous avez des problèmes, vous pouvez récupérer ma compilation :
Blender r33949 Ubuntu 64 bits compilée le 30/12/2010

Il faut passer en 64 bits ! Cool

_________________
PBRN3d

                                                                                                                                     
avatar
Admin
Admin

Messages : 147
Date d'inscription : 22/04/2010
Localisation : Cognac, Charente

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Sam 8 Jan - 0:27




BONNE ET HEUREUSE ANNEE 2011

Salut a tous,

Je suis encore un débutant sur Blender (env.5 mois) j'ai lu le tutoriel Comment compiler Blender 2.5 avec SCons Procédure pour la Karmic Koala 9.10 et la Lynx Lucid 10.04

Depuis quelques semaines je suis passé d'Ubuntu Ultimate Edition 2.6 ( 9.10) à la 2.7 (10.04 LTS).
Je n'arrive pas récupère quelques dépendances au compilateur bien qu'avant j'ai fait dans la console sudo apt-get update après avoir activé tous les dépôts dans sources de logiciels sauf code source; je crois mon que problème viens de mon sources.list.

Quelqu'un a- t- il une idée pour mon sources.list ?

Mon fichier sources.list

Code:
# deb cdrom:[Ubuntu 10.04 LTS _Lucid Lynx_ - Release i386 (20100429)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://cm.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://cm.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://cm.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid universe
deb http://cm.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://cm.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://cm.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cm.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://cm.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://www.geekconnection.org/remastersys/repository ubuntu/

LES ERREURS

Code:
serviteur@creation:~$ sudo apt-get install build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-

Lecture des listes de paquets... Fait

Construction de l'arbre des dépendances     

Lecture des informations d'état... Fait

build-essential est déjà la plus récente version disponible.

build-essential passé en « installé manuellement ».

scons est déjà la plus récente version disponible.

g++ est déjà la plus récente version disponible.

g++ passé en « installé manuellement ».

libx11-dev est déjà la plus récente version disponible.

libx11-dev passé en « installé manuellement ».

libgl1-mesa-dev est déjà la plus récente version disponible.

libgl1-mesa-dev passé en « installé manuellement ».

E: Impossible de trouver le paquet libxi

serviteur@creation:~$ dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev

No command 'dev' found, did you mean:

 Command 'xev' from package 'x11-utils' (main)

 Command 'dav' from package 'dav-text' (universe)

 Command 'ev' from package 'radiance' (universe)

 Command 'rev' from package 'util-linux' (main)

 Command 'ddv' from package 'ncbi-tools-x11' (universe)

 Command 'mev' from package 'gpm' (universe)

 Command 'rdev' from package 'util-linux' (main)

dev : commande introuvable

serviteur@creation:~$ libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-

libtiff4-dev : commande introuvable

serviteur@creation:~$ dev libsamplerate0-dev libjack-dev libavformat-dev libxvidcore4-dev libogg-dev

No command 'dev' found, did you mean:

 Command 'xev' from package 'x11-utils' (main)

 Command 'dav' from package 'dav-text' (universe)

 Command 'ev' from package 'radiance' (universe)

 Command 'rev' from package 'util-linux' (main)

 Command 'ddv' from package 'ncbi-tools-x11' (universe)

 Command 'mev' from package 'gpm' (universe)

 Command 'rdev' from package 'util-linux' (main)

dev : commande introuvable

serviteur@creation:~$ libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev

libfaac-dev : commande introuvable

serviteur@creation:~$ libswscale-dev libavdevice-dev subversion

libswscale-dev : commande introuvable
 

serviteur@creation:~$ sudo apt-get install libxvidcore

Lecture des listes de paquets... Fait

Construction de l'arbre des dépendances     

Lecture des informations d'état... Fait

E: Impossible de trouver le paquet libxvidcore­

serviteur@creation:~$ sudo apt-get install libxvidcore4-dev­

Lecture des listes de paquets... Fait

Construction de l'arbre des dépendances     

Lecture des informations d'état... Fait

E: Impossible de trouver le paquet libxvidcore4-dev­

serviteur@creation:~$

[code]

Cordialement

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Sam 8 Jan - 11:15

Salut serviteur et bienvenue à toi !
Pour ton problème, si tu n'as pas bidouillé ton source.list, ça ne vient pas du sources.list !
A priori, la ligne :
Code:
# deb-src http://archive.canonical.com/ubuntu lucid partner
N'est pas activée. C'est ici que se trouvent les bibliothèques de développement !
Tu peux essayer de l'activer en supprimant le #
Tu enregistre et tu fait dans le terminal :
Code:
sudo apt-get update
Tu peux faire aussi un nettoyage du cache :
Code:
sudo apt-get autoclean
ou
sudo apt-get clean

Tout sur
sources.list suivant les versions
Ce qu'il doit y avoir dans le sources.list pour Lynx Lucid
Je te conseillerai quand même de passer sous Merkat Mavrick qui est beaucoup plus élaborée !

Concernant les bibliothèques
Pour installer scons et les dépendances, il faut au moins faire ça :
Code:
sudo apt-get install build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-
dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev
libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-
dev libsamplerate0-dev libjack-dev libavformat-dev libxvidcore4-dev libogg-dev
libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev
libswscale-dev libavdevice-dev subversion
Refait la commande complète ci-dessus, la tienne est incomplète ! C'est pour ça qu'il ne trouve pas les bibliothèques de développement ! Rolling Eyes

Supplément :
Pour les bibliothèques manquantes à la compilation :
Si vous avez une erreur vous indiquant par exemple qu'il ne trouve pas -lxvid
Ce sont des librairies de développement nécessaires à la compilation qui ne sont pas forcément
installées dans votre système
Remplacez -l par lib et ajoutez -dev à la fin ce qui donne :
Il faut transformer -lxvid en libxvid-dev
Donc pour cette librairie manquante tapez dans le terminal :
Code:
sudo apt-get install libxvid-dev
et appuyez sur Entrée.
Relancez la compilation et si une autre erreur indiquant qu'il manque une autre librairie appliquez le
même schéma que précédemment pour chaque librairie manquante jusqu'à ce qu'il n'y ait plus
d'erreurs.
Tiens moi au courant de l'évolution !
@++
Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Sam 8 Jan - 20:07

Salut Patrice,

Merci pour la bienvenue dans ton forum.
Je n'ai toujours pas pu réussit même après avoir suivi et utiliser les différentes commandes.

Pour ton problème, si tu n'as pas bidouillé ton source.list, ça ne vient pas du sources.list !

Je n'est pas bidouillé mon sources.list ; voici le fichier par défaut après l'installation:

Code:
#deb cdrom:[Ubuntu 10.04 LTS _Lucid Lynx_ - Release i386 (20100429)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://us.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security multiverse



Je te conseillerai quand même de passer sous Merkat Mavrick qui est beaucoup plus élaborée !

Après avoir lu la documentation sur les version LTS d'ubuntu http://doc.ubuntu-fr.org/lts ( La ligne LTS s'adresse principalement aux milieux qui nécessitent une stabilité à long terme dans des environnements peu changeants), j'ai décidé de rester sur la 10.04 LTS pour avoir un système stable et maintenu pour une durée étendue, car n'ayant pas une connexion rapide cela me rendait instable presque touts les 6 mois en passant d'une version a l'autre car je devrait toujours réinstalle mon système. J'ai depuis quelque jours en DVD Ultimate Edtion 2.8 basée sur la 10.10 Merkat Mavrick mais je préfères resté par la grâce de Dieu sur la LTS.

Les versions Ultimate Édition http://ultimateedition.info/ (versions assez élaborée avec plusieurs environnements graphiques et riche en paquets , il ressemble un peu au version Mandriva Spring DVD) que j'installe sont en DVD généralement les tailles varies de 1.7Go à 3.2Go, car si j'installe la version CD cela me coûterais trop chère pour ajouter les paquets que je n'est. De plus , J'ai une connexion très lente le maxi est souvent a 20kb/s, quand je souhaite ajouter des paquets assez lourd via les dépôts, il faut que je portes mon Pc ailleurs pour aller le faire et c'est fastidieux....

Après avoir activée et enregistrée:
Code:
deb-src http://archive.canonical.com/ubuntu lucid partner

J'ai fais un nettoyage du cache:

Code:
serviteur@creation:~$ sudo apt-get autoclean
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
Del non-free-codecs 5medibuntu1 [2 640B]
Del libaudclient2 2.4-1~webupd8~lucid [29,2kB]
Del w32codecs 1:20100303-0.0medibuntu1 [21,1MB]
Del dpkg 1.15.5.6ubuntu4.4 [2 192kB]
Del googleearth 5.1.3533.1731-0medibuntu1 [17,7MB]
Del audacious-plugins 2.4-1~webupd8~lucid [2 298kB]
Del audacious 2.4-1~webupd8~lucid [417kB]
Del libaudcore1 2.4-1~webupd8~lucid [114kB]
serviteur@creation:~

Ensuite, j'ai essayé plusieurs fois avec les mêmes messages:

Code:
serviteur@creation:~$ sudo apt-get update
Atteint http://security.ubuntu.com lucid-security Release.gpg                                                                                                                                       
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-fr                                                                                                                         
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-fr                                                                                                                   
Réception de : 1 http://deb.playonlinux.com lucid Release.gpg [197B]                                                                                                                               
Atteint http://packages.medibuntu.org karmic Release.gpg                                                                                                                                           
Atteint http://archive.canonical.com lucid Release.gpg                                                                                                                                             
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-fr                                                                                                                             
Atteint http://cm.archive.ubuntu.com lucid Release.gpg                                                                                                                                             
Atteint http://cm.archive.ubuntu.com/ubuntu/ lucid/main Translation-fr                                                                                                                             
Atteint http://cm.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-fr                                                                                                                       
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Ign http://ppa.launchpad.net/akirad/akirad/ubuntu/ lucid/main Translation-fr                                                                                                                       
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-fr                                                                                                                     
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-fr                                                                                                                   
Atteint http://cm.archive.ubuntu.com/ubuntu/ lucid/universe Translation-fr                                                                                                                         
Atteint http://cm.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-fr                                                                                                                       
Atteint http://cm.archive.ubuntu.com lucid-updates Release.gpg                                                                                                                                     
Ign http://cm.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-fr                                                                                                                         
Ign http://cm.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-fr                                                                                                                   
Ign http://cm.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-fr                                                                                                                     
Ign http://cm.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-fr                                                                                                                   
Atteint http://archive.canonical.com lucid Release                                                                                                                                                 
Atteint http://cm.archive.ubuntu.com lucid Release                                                                                                                                                 
Ign http://ppa.launchpad.net/akirad/ppa/ubuntu/ lucid/main Translation-fr                                                                                                                         
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Ign http://ppa.launchpad.net/compiz/ubuntu/ lucid/main Translation-fr                                                                                                                               
Atteint http://ppa.launchpad.net karmic Release.gpg                                                                                                                                               
Ign http://ppa.launchpad.net/bogdanb/ppa/ubuntu/ karmic/main Translation-fr                                                                                                                       
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Ign http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu/ lucid/main Translation-fr                                                                                                           
Réception de : 2 http://downloadue.info lucid Release.gpg                                                                                                                                         
Ign http://downloadue.info/repo/ lucid/all Translation-fr                                                                                                                                         
Ign http://www.geekconnection.org ubuntu/ Release.gpg                                                                                                                                             
Ign http://www.geekconnection.org/remastersys/repository/ ubuntu/ Translation-fr                                                                                                                   
Atteint http://security.ubuntu.com lucid-security Release                                                                                                                                         
Atteint http://cm.archive.ubuntu.com lucid-updates Release                                                                                                                                         
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Ign http://ppa.launchpad.net/mizuno-as/gimp-painter/ubuntu/ lucid/main Translation-fr                                                                                                             
Atteint http://ppa.launchpad.net lucid Release.gpg                                                                                                                                                 
Atteint http://archive.canonical.com lucid/partner Packages                                                                                                                                       
Ign http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ lucid/main Translation-fr                                                                                                               
Ign http://ppa.launchpad.net karmic Release.gpg                                                                                                                                                   
Ign http://ppa.launchpad.net/team-xbmc/karmic-ppa/ubuntu/ karmic/main Translation-fr                                                                                                               
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Ign http://packages.medibuntu.org/ karmic/free Translation-fr                                                                                                                                     
Atteint http://security.ubuntu.com lucid-security/main Packages                                                                                                                                   
Ign http://downloadue.info lucid Release                                                                                                                                                           
Ign http://www.geekconnection.org ubuntu/ Release                                                                                                                                                 
Atteint http://cm.archive.ubuntu.com lucid/main Packages                                                                                                                                           
Atteint http://cm.archive.ubuntu.com lucid/restricted Packages                                                                                                                                     
Atteint http://cm.archive.ubuntu.com lucid/main Sources                                                                                                                                           
Atteint http://cm.archive.ubuntu.com lucid/restricted Sources                                                                                                                                     
Atteint http://cm.archive.ubuntu.com lucid/universe Packages                                                                                                                                       
Atteint http://ppa.launchpad.net karmic Release                                                                                                                                                   
Atteint http://archive.canonical.com lucid/partner Sources                                                                                                                                         
Atteint http://security.ubuntu.com lucid-security/restricted Packages                                                                                                                             
Atteint http://security.ubuntu.com lucid-security/main Sources                                                                                                                                     
Atteint http://security.ubuntu.com lucid-security/restricted Sources                                                                                                                               
Atteint http://security.ubuntu.com lucid-security/universe Packages                                                                                                                               
Atteint http://security.ubuntu.com lucid-security/universe Sources                                                                                                                                 
Atteint http://security.ubuntu.com lucid-security/multiverse Packages                                                                                                                             
Ign http://downloadue.info lucid/all Packages                                                                                                                                                     
Atteint http://cm.archive.ubuntu.com lucid/universe Sources                                                                                                                                       
Atteint http://cm.archive.ubuntu.com lucid/multiverse Packages                                                                                                                                     
Atteint http://cm.archive.ubuntu.com lucid/multiverse Sources                                                                                                                                     
Ign http://www.geekconnection.org ubuntu/ Packages                                                                                                                                                 
Atteint http://cm.archive.ubuntu.com lucid-updates/main Packages                                                                                                                                   
Atteint http://cm.archive.ubuntu.com lucid-updates/restricted Packages                                                                                                                             
Atteint http://cm.archive.ubuntu.com lucid-updates/main Sources                                                                                                                                   
Atteint http://cm.archive.ubuntu.com lucid-updates/restricted Sources                                                                                                                             
Atteint http://cm.archive.ubuntu.com lucid-updates/universe Packages                                                                                                                               
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Atteint http://ppa.launchpad.net lucid Release                                                                                                                                                     
Ign http://ppa.launchpad.net karmic Release                                                                                                                                                       
Atteint http://security.ubuntu.com lucid-security/multiverse Sources                                                                                                                               
Ign http://packages.medibuntu.org/ karmic/non-free Translation-fr                                                                                                                                 
Atteint http://cm.archive.ubuntu.com lucid-updates/universe Sources                                                                                                                               
Atteint http://cm.archive.ubuntu.com lucid-updates/multiverse Packages                                                                                                                             
Ign http://downloadue.info lucid/all Packages                                                                                                                                                     
Ign http://www.geekconnection.org ubuntu/ Packages                                                                                                                                                 
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                           
Atteint http://ppa.launchpad.net lucid/main Sources                                                                                                                                               
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                               
Atteint http://ppa.launchpad.net lucid/main Sources                                                                                                                                               
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                               
Atteint http://cm.archive.ubuntu.com lucid-updates/multiverse Sources                                                                                                                             
Atteint http://downloadue.info lucid/all Packages                                                                                                                                                 
Atteint http://www.geekconnection.org ubuntu/ Packages                                                                                                                                             
Atteint http://ppa.launchpad.net karmic/main Packages                                                                                                                                             
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                               
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                               
Atteint http://ppa.launchpad.net lucid/main Packages                                                                                                                                               
Atteint http://packages.medibuntu.org karmic Release                                                                                                                                               
Ign http://ppa.launchpad.net karmic/main Packages                                                                                                                                                 
Atteint http://packages.medibuntu.org karmic/free Packages                                                                                                                                         
Ign http://ppa.launchpad.net karmic/main Packages                                                                                                                                                 
Err http://ppa.launchpad.net karmic/main Packages                                                                           
  404  Not Found
Atteint http://packages.medibuntu.org karmic/non-free Packages                                         
Ign http://deb.playonlinux.com/ lucid/main Translation-fr                                 
Atteint http://packages.medibuntu.org karmic/free Sources             
Réception de : 3 http://deb.playonlinux.com lucid Release [1 722B]
Err http://deb.playonlinux.com lucid Release               
 
Atteint http://packages.medibuntu.org karmic/non-free Sources
198o réceptionnés en 17s (11o/s)   
Lecture des listes de paquets... Fait
W: Une erreur est survenue lors de la vérification de la signature. Le dépot n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur GPG : http://deb.playonlinux.com lucid Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY E0F72778C4676186

W: Impossible de récupérer http://deb.playonlinux.com/dists/lucid/Release 

W: Impossible de récupérer http://ppa.launchpad.net/team-xbmc/karmic-ppa/ubuntu/dists/karmic/main/binary-i386/Packages.gz  404  Not Found

W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
serviteur@creation:~$


Concernant les bibliothèques sachez que la version Ultimate édition installe par défaut certaines librairies contenu dans le DVD commes: build-essential....
Je crois également que d'autres librairies (scons.....) ont été installées avoir ajouter et installé le dépôt :
Code:
http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu
Je copie complètement la commande mais en collant dans le terminal il est reduit (incomplet) parce que je crois que certains sont déjà installé.

Code:
serviteur@creation:~$ sudo apt-get install build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-
[sudo] password for serviteur:


Les commandes :
serviteur@creation:~$ sudo apt-get install build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
build-essential passé en « installé manuellement ».
scons est déjà la plus récente version disponible.
g++ est déjà la plus récente version disponible.
g++ passé en « installé manuellement ».
libx11-dev est déjà la plus récente version disponible.
libx11-dev passé en « installé manuellement ».
libgl1-mesa-dev est déjà la plus récente version disponible.
libgl1-mesa-dev passé en « installé manuellement ».
E: Impossible de trouver le paquet libxi
serviteur@creation:~$ dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev
No command 'dev' found, did you mean:
 Command 'xev' from package 'x11-utils' (main)
 Command 'dav' from package 'dav-text' (universe)
 Command 'ev' from package 'radiance' (universe)
 Command 'rev' from package 'util-linux' (main)
 Command 'ddv' from package 'ncbi-tools-x11' (universe)
 Command 'mev' from package 'gpm' (universe)
 Command 'rdev' from package 'util-linux' (main)
dev : commande introuvable
serviteur@creation:~$ libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-
libtiff4-dev : commande introuvable
serviteur@creation:~$ dev libsamplerate0-dev libjack-dev libavformat-dev libxvidcore4-dev libogg-dev
No command 'dev' found, did you mean:
 Command 'xev' from package 'x11-utils' (main)
 Command 'dav' from package 'dav-text' (universe)
 Command 'ev' from package 'radiance' (universe)
 Command 'rev' from package 'util-linux' (main)
 Command 'ddv' from package 'ncbi-tools-x11' (universe)
 Command 'mev' from package 'gpm' (universe)
 Command 'rdev' from package 'util-linux' (main)
dev : commande introuvable
serviteur@creation:~$ libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev
libfaac-dev : commande introuvable
serviteur@creation:~$ libswscale-dev libavdevice-dev subversion

serviteur@creation:~$ libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev
libfaac-dev : commande introuvable
serviteur@creation:~$ sudo apt-get install libxvid-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libxvid-dev
serviteur@creation:~$


serviteur@creation:~$ libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev
libfaac-dev : commande introuvable
serviteur@creation:~$ sudo apt-get install libxvid-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libxvid-dev
serviteur@creation:~$ sudo apt-get install libxvid-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libxvid-dev
serviteur@creation:~$ sudo apt-get install build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
build-essential passé en « installé manuellement ».
scons est déjà la plus récente version disponible.
g++ est déjà la plus récente version disponible.
g++ passé en « installé manuellement ».
libx11-dev est déjà la plus récente version disponible.
libx11-dev passé en « installé manuellement ».
libgl1-mesa-dev est déjà la plus récente version disponible.
libgl1-mesa-dev passé en « installé manuellement ».
E: Impossible de trouver le paquet libxi
serviteur@creation:~$ dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev
No command 'dev' found, did you mean:
 Command 'xev' from package 'x11-utils' (main)
 Command 'dav' from package 'dav-text' (universe)
 Command 'ev' from package 'radiance' (universe)
 Command 'rev' from package 'util-linux' (main)
 Command 'ddv' from package 'ncbi-tools-x11' (universe)
 Command 'mev' from package 'gpm' (universe)
 Command 'rdev' from package 'util-linux' (main)
dev : commande introuvable
serviteur@creation:~$ libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-
libtiff4-dev : commande introuvable
serviteur@creation:~$ dev libsamplerate0-dev libjack-dev libavformat-dev libxvidcore4-dev libogg-dev
No command 'dev' found, did you mean:
 Command 'xev' from package 'x11-utils' (main)
 Command 'dav' from package 'dav-text' (universe)
 Command 'ev' from package 'radiance' (universe)
 Command 'rev' from package 'util-linux' (main)
 Command 'ddv' from package 'ncbi-tools-x11' (universe)
 Command 'mev' from package 'gpm' (universe)
 Command 'rdev' from package 'util-linux' (main)
dev : commande introuvable
serviteur@creation:~$ libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev
libfaac-dev : commande introuvable
serviteur@creation:~$ libswscale-dev libavdevice-dev subversion
libswscale-dev : commande introuvable
serviteur@creation:~$

Cordialement
serviteur

GOD BLESS YOU !!!


Dernière édition par serviteur le Mer 12 Jan - 2:00, édité 1 fois

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Dim 9 Jan - 12:37

Salut serviteur,
Excuse moi pour la réponse un peu tardive, mais c'est le Week-End !
Bon, si tu veux rester sous 10.04 LTS, ce n'est pas un problème !
Je te disais juste ça ne sachant pas que tu avais une connexion Internet aussi mauvaise !
Je me demande comment tu vas pouvoir télécharger les sources de Blender pour le compiler (autour de 280 Mo) !

Donc pour revenir à ton problème qui devient plus clair !
Si tu copie la ligne entière dans le Terminal, il doit la copier en entier que les dépendances soient installée ou pas !
Donc si il ne copie pas la ligne entière ! Shocked C'est la source de ton problème !
Si les dépendances sont installées, il te dira que la version installée est la plus récente et il installera celles qui ne sont pas installées !

Autre chose, si il te dit que telle librairie n'est pas installée, fait :
Code:
sudo apt-get install libxvid-dev
c'est un exemple pour cette librairie, a toi d'appliquer le même schéma pour toutes celles qui manquent !
Il y a deux types de librairies, celles qui sont compilées par exemple libxvid.so, mais Blender a besoin de la librairies dites de développement qu'il utilise pour la compilation : libxvid-dev par exemple !
Ces librairies ne sont pas installées par défaut et il faut les installer

Pour conclure, tant que tu n'auras pas installé toutes les librairies nécessaires, ça ne pourra pas marcher !
C'est aussi dommage d'avoir une connexion aussi faible ! Je suis d'accord que dans certains coins on ne choisi pas ! Crying or Very sad

Il est aussi nécessaire de faire les mises à jour de Ubuntu après son installation !

Je pense aussi que tu ne peux pas visionner le tutoriel vidéo ci-dessus vu ta connexion internet !
Crying or Very sad
Tiens moi au courant !
@++

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Mer 12 Jan - 1:56

Salut pbrn,

J'ai également essayé mais sans succès.
Autre chose, si il te dit que telle librairie n'est pas installée, fait :
Code:
sudo apt-get install libxvid-de

Code:
serviteur@creation:~$ sudo apt-get install libxvid-de
[sudo] password for serviteur:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libxvid-de
serviteur@creation:~$

Est ce que je doit activer ou pas Code source dans les sources de logiciels ? Chez moi par défaut il est désactivé;

Je vais essayé de changer mon sources.list.

Je me demande comment tu vas pouvoir télécharger les sources de Blender pour le compiler (autour de 280 Mo) !

Comme je l'ai dit plus haut quand j'ai besoin de télécharger les sources (dépôts) assez lourd je vais avec mon Pc ailleurs en payant un certains sommes pour le faire où la connexion est acceptable.

Y'a t-il une astuce (scripts...) pour télécharger les sources avec ses dépendances sur un disque usb à partir d'un poste avec windows xp, vista ou 7... ?

C'est aussi dommage d'avoir une connexion aussi faible ! Je suis d'accord que dans certains coins on ne choisi pas !

Avant la connexion était acceptable, mais mon fournisseur (www.camtel.cm)
à tellement vendu ces modems internet qu'il n'a pas améliorer les capacités de son réseau qu'il y a saturation.

Comme on le sait, le processeurs récents sont tous en 64 bits aujourd'hui !
Donc pourquoi ne pas utiliser toute la puissance de nos processeurs ?
La première condition, c'est d'avoir installé un OS 64 bits pour pouvoir utiliser toute la puissance des processeurs modernes !
Dans la modélisation 3d, ça devient incontournable d'utiliser un OS 64 bits !
Utiliser un OS 32 bits avec un processeur 64 bits, c'est purement du gâchis de performances ! 
Donc aujourd'hui utilisons toutes les performance de nos processeurs !
Donc, maintenant je vous propose d'utiliser les versions de Blender compilées pour Ubuntu 64 bits !
Je vous propose aussi un tutoriel pour compiler Blender en 64 bits :

Quelle est la configuration de ton PC en 64 bits (modèle AMD ou Intel et la vitesse du processeur....) ?

Quels avantages ya t-il a installé Ubuntu en 64 bits ou Ubuntu sur un PowerPC G4?


En attendant je vais me contenter de bosser avec Blender 2.56 Beta avec l'installation classique.

Quand la version officielle sortira aura t-on encore besoin de compiler comme sur le tutoriel ?

Cordialement.

QUE DIEU VOUS BENISSE !!!

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Mer 12 Jan - 11:36

Salut serviteur,
Si tu regarde bien :
ça ne peut pas marcher :
Ce n'est pas sudo apt-get install libxvid-de tu as "mangé" le v à la fin et c'est normal qu'il ne la trouve pas !
Il faut entrer
Code:
sudo apt-get install libxvid-dev
Visiblement, ce n'est pas un problème de sources.list, mais plutôt des erreurs de syntaxe dans les lignes de commande !

On peut installer les sources(280 Mo) sur une clé USB d'au moins 1Go pour ensuite les mettre sur ton disque dur. Mais à chaque compilation il faut les mettre à jour les sources ! ça rique quand même d'être "galère".

J'espère qu'ils ne te font pas payer la connexion trop chère !!
pale

Ma configuration est un Intel 4 cœurs(4x2,67 GigaHertz), 8 Go de Ram, une carte graplique NVIDIA 450GT avec GPUs que je me suis assemblé moi même.
Donc, pour Blender 2.5x, il faut éviter les ordinateurs dits de Bureautique !

L'intérêt d'utiliser un OS 64 bits se justifie pour les applications gourmandes en ressources et bien entendu, il faut un logiciel capable de tourner en 64 bits, ce qui est le cas de Blender , même certains moteurs de rendu externes sont capables de tourner qu'en 64 bits !
Tous les processeurs modernes ont une architecture 64 bits et c'est une perte de performance que d'utiliser que la moitié du registre du Processeur ! Donc en théorie, les données sont traitées deux fois plus vite qu'avec un 32 bits.

On est pas obligé de compiler Blender !
On le fait uniquement pour avoir les dernières avancées et un programme plus prêt de sa machine, d'avoir les dernières corrections de bugs et ça marche mieux quand c'est compilé sur sa propre machine !
Il faut savoir que même quand la version officielle sera sortie, Blender continue à évoluer !
En moyenne, je le compile toutes les semaines et je n'utilise pas les versions officielles !

Donc, oui tu peux utiliser les version qui sortent au fur et à mesure.
Vu les problèmes divers que tu rencontre !
Rolling Eyes

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Jeu 13 Jan - 0:02

Salut pbrn,

J'ai changer de serveur et ensuite :

serviteur@creation:~$ sudo apt-get update

Code:
serviteur@creation:~$ sudo apt-get update
[sudo] password for serviteur:
Atteint http://archive.canonical.com lucid Release.gpg                       
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-fr         
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Ign http://ppa.launchpad.net/akirad/akirad/ubuntu/ lucid/main Translation-fr 
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Atteint http://ftp.oleane.net lucid Release.gpg                               
Atteint http://ftp.oleane.net/ubuntu/ lucid/main Translation-fr               
Réception de : 1 http://downloadue.info lucid Release.gpg                     
Ign http://downloadue.info/repo/ lucid/all Translation-fr                     
Ign http://www.geekconnection.org ubuntu/ Release.gpg                         
Ign http://www.geekconnection.org/remastersys/repository/ ubuntu/ Translation-fr
Atteint http://archive.canonical.com lucid Release                           
Ign http://ppa.launchpad.net/akirad/ppa/ubuntu/ lucid/main Translation-fr     
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Ign http://ppa.launchpad.net/compiz/ubuntu/ lucid/main Translation-fr         
Atteint http://ppa.launchpad.net karmic Release.gpg                           
Ign http://ppa.launchpad.net/bogdanb/ppa/ubuntu/ karmic/main Translation-fr   
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Ign http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu/ lucid/main Translation-fr
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Atteint http://ftp.oleane.net/ubuntu/ lucid/restricted Translation-fr         
Atteint http://ftp.oleane.net/ubuntu/ lucid/universe Translation-fr           
Atteint http://ftp.oleane.net/ubuntu/ lucid/multiverse Translation-fr         
Atteint http://ftp.oleane.net lucid-updates Release.gpg                       
Ign http://ftp.oleane.net/ubuntu/ lucid-updates/main Translation-fr           
Ign http://ftp.oleane.net/ubuntu/ lucid-updates/restricted Translation-fr     
Ign http://ftp.oleane.net/ubuntu/ lucid-updates/universe Translation-fr       
Ign http://ftp.oleane.net/ubuntu/ lucid-updates/multiverse Translation-fr     
Atteint http://ftp.oleane.net lucid-security Release.gpg                     
Ign http://downloadue.info lucid Release                                     
Atteint http://archive.canonical.com lucid/partner Packages                   
Ign http://www.geekconnection.org ubuntu/ Release                             
Ign http://ppa.launchpad.net/mizuno-as/gimp-painter/ubuntu/ lucid/main Translation-fr
Atteint http://ppa.launchpad.net lucid Release.gpg                           
Ign http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ lucid/main Translation-fr
Atteint http://ppa.launchpad.net lucid Release                               
Atteint http://ppa.launchpad.net lucid Release                               
Atteint http://ppa.launchpad.net lucid Release                               
Atteint http://ppa.launchpad.net karmic Release                               
Atteint http://ppa.launchpad.net lucid Release                               
Ign http://ftp.oleane.net/ubuntu/ lucid-security/main Translation-fr         
Ign http://ftp.oleane.net/ubuntu/ lucid-security/restricted Translation-fr   
Ign http://ftp.oleane.net/ubuntu/ lucid-security/universe Translation-fr     
Ign http://ftp.oleane.net/ubuntu/ lucid-security/multiverse Translation-fr   
Atteint http://ftp.oleane.net lucid Release                                   
Atteint http://ftp.oleane.net lucid-updates Release                           
Atteint http://archive.canonical.com lucid/partner Sources                   
Ign http://downloadue.info lucid/all Packages                                 
Ign http://www.geekconnection.org ubuntu/ Packages                           
Atteint http://ppa.launchpad.net lucid Release                               
Atteint http://ppa.launchpad.net lucid Release                               
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://ppa.launchpad.net lucid/main Sources                           
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://ppa.launchpad.net lucid/main Sources                           
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://ftp.oleane.net lucid-security Release                         
Atteint http://ppa.launchpad.net karmic/main Packages                         
Ign http://downloadue.info lucid/all Packages                                 
Ign http://www.geekconnection.org ubuntu/ Packages                           
Atteint http://ftp.oleane.net lucid/main Sources                             
Atteint http://ftp.oleane.net lucid/restricted Sources                       
Atteint http://ftp.oleane.net lucid/main Packages                             
Atteint http://ftp.oleane.net lucid/restricted Packages                       
Atteint http://ftp.oleane.net lucid/multiverse Sources                       
Atteint http://ftp.oleane.net lucid/universe Sources                         
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://ppa.launchpad.net lucid/main Packages                         
Atteint http://downloadue.info lucid/all Packages                             
Atteint http://www.geekconnection.org ubuntu/ Packages                       
Réception de : 2 http://ftp.oleane.net lucid/universe Packages [5 448kB]
Réception de : 3 http://ftp.oleane.net lucid/multiverse Packages [180kB]     
Réception de : 4 http://ftp.oleane.net lucid-updates/main Packages [423kB]   
Réception de : 5 http://ftp.oleane.net lucid-updates/restricted Packages [3 240B]
Réception de : 6 http://ftp.oleane.net lucid-updates/restricted Sources [1 443B]
Réception de : 7 http://ftp.oleane.net lucid-updates/main Sources [170kB]     
Réception de : 8 http://ftp.oleane.net lucid-updates/multiverse Sources [3 677B]
Réception de : 9 http://ftp.oleane.net lucid-updates/universe Sources [62,5kB]
Réception de : 10 http://ftp.oleane.net lucid-updates/universe Packages [176kB]
Réception de : 11 http://ftp.oleane.net lucid-updates/multiverse Packages [7 669B]
Réception de : 12 http://ftp.oleane.net lucid-security/main Packages [122kB]
Réception de : 13 http://ftp.oleane.net lucid-security/restricted Packages [14B]
Réception de : 14 http://ftp.oleane.net lucid-security/restricted Sources [14B]
Réception de : 15 http://ftp.oleane.net lucid-security/main Sources [40,6kB] 
Réception de : 16 http://ftp.oleane.net lucid-security/multiverse Sources [660B]
Réception de : 17 http://ftp.oleane.net lucid-security/universe Sources [16,1kB]
Réception de : 18 http://ftp.oleane.net lucid-security/universe Packages [55,4kB]
Réception de : 19 http://ftp.oleane.net lucid-security/multiverse Packages [2 003B]
4 718ko réceptionnés en 11min 15s (6 980o/s)                                 
Lecture des listes de paquets... Fait
serviteur@creation:~$

Tout se passe bien....


Je crois que j'ai fait une errreur de copier coller sur le forum, car c'est toujours sans succès.

Code:
serviteur@creation:~$ sudo apt-get install libxvid-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances     
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libxvid-dev
serviteur@creation:~$


On peut installer les sources(280 Mo) sur une clé USB d'au moins 1Go pour ensuite les mettre sur ton disque dur. Mais à chaque compilation il faut les mettre à jour les sources ! ça rique quand même d'être "galère".

Comment installer sur une clé USB ou disque usb, peux-tu me donner la procédure?

@+

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Jeu 13 Jan - 11:47

Salut,
Va dans le Synaptic :
Système>Administration>Gestionaire de paquets Synaptic
Ensuite fait une recherche sur cette librairie !
Tu verras si elle est disponible, si ce n'est pas le cas, c'est qu'il manque le dépôt correspondant ou que tu ne peut pas y accéder ! pale

Les sources de Blender, tu crée un répertoire, par exemple : blender-svn, tu te mets dans ce répertoire et tu télécharge les sources.
Ensuite, sur ton PC, tu copie le répertoire blender-svn avec tout ce qu'il y a à l'intérieur sur ton disque dur !

Une question, est-ce que la version blender 2.56a officielle fonctionne sur ton PC Question

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Jeu 13 Jan - 17:36

Salut,

Va dans le Synaptic :
Système>Administration>Gestionaire de paquets Synaptic
Ensuite fait une recherche sur cette librairie !

La librairie libxvid-dev dans la recherche ne me donne rien, par contre la librairie libxvid me donne comme recherche libxvidcore-dev qui n'est pas installée.
Les librairies build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-dev libglu1-mesa-dev libjpeg62-dev python2.6-dev zlib1g-dev sont tous disponibles et déjà installées
Disponible: libpng12-dev libfreetype6-dev sont déjà installées demande une mise à jour

Disponible: libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev libfftw3-dev libsamplerate0-dev libjack-dev libavformat-dev libogg-dev libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev libswscale-dev libavdevice-dev subversion mais ne sont pas encore installées

Pas disponible: libxvidcore4-dev

Les sources de Blender, tu crée un répertoire, par exemple : blender-svn, tu te mets dans ce répertoire et tu télécharge les sources.
Ensuite, sur ton PC, tu copie le répertoire blender-svn avec tout ce qu'il y a à l'intérieur sur ton disque dur !

Dans le cas ou je dois faire une mise à jour, je dois repartir au cybercafé... (avec l' OS XP installé...) avec le clé ou disque USB les téléchargé a nouveau ensuite, sur ton PC, tu copie le répertoire blender-svn avec tout ce qu'il y a à l'intérieur sur ton disque dur !

Une question, est-ce que la version blender 2.56a officielle fonctionne sur ton PC

Fonctionne comment?

J'ai plutôt Blender-2.56-beta-linux-glibc27-i686, il fonctionne bien que je n'est eu encore a faire de grosse production.

Par la grâce de Dieu je compte très bientôt passé à une architecture 64 bits, j'ai de quelques info si c'est possible:

Ma configuration est un Intel 4 cœurs(4x2,67 GigaHertz), 8 Go de Ram, une carte graplique NVIDIA 450GT avec GPUs que je me suis assemblé moi même.

Pourquoi ton choix sur un Intel 4 cœurs au lieu d'un AMD ATHLON 4 cœurs ?
La carte graphique NVIDIA 450GT en quoi diffère t-elle des autres cartes graphiques NVIDIA; moi, j'ai une Nvidia Geforce 8400 GS.
GPUs je n'ai aucune connaissance dessus.

PS: Comment ajouter une image et un lien au forum?

Cordialement
@+

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Jeu 13 Jan - 19:57

Salut,
serviteur a écrit:
Disponible: libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev libfftw3-dev libsamplerate0-dev libjack-dev libavformat-dev libogg-dev libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev libswscale-dev libavdevice-dev subversion mais ne sont pas encore installées
Alors installe les à partir du Synaptic !
C'est bien les librairies de développement qui te manquent, il faut les installer !
serviteur a écrit:Dans le cas ou je dois faire une mise à jour
Tu les fait avec ta clé USB, par contre, il faut que tu "écrase" sur ton disque dur !
serviteur a écrit:Dans le cas ou je dois faire une mise à jour
A chaque fois que tu veux faire une nouvelle compilation
serviteur a écrit:J'ai plutôt Blender-2.56-beta-linux-glibc27-i686, il fonctionne bien
Donc, ça prouve que c'est un problème de bibliothèques de développent qui ne sont pas installées et nécéssaires pour compiler Blender !
serviteur a écrit:
Pourquoi ton choix sur un Intel 4 cœurs au lieu d'un AMD ATHLON 4 cœurs ?
La carte graphique NVIDIA 450GT en quoi diffère t-elle des autres cartes graphiques NVIDIA; moi, j'ai une Nvidia Geforce 8400 GS.
GPUs je n'ai aucune connaissance dessus.
Peu importe Intel ou AMD, c'est une question personnelle !
Chez NVIDIA, la 450GT est beaucoup plus performante que la Gforce 8400 GS, après c'est une baisse de performances et les dernières cartes Graphiques gèrent l'OpenCL en plus de l'OpenGL (Puissance graphique décuplée)
Aujourd'hui les cartes graphique modernes sont équipées de GPUs, ce sont des microprocesseurs qui déchargent le CPU (processeur central) tous les traitements graphiques doivent passer par les GPUs pour avoir une grande puissance de calcul !
serviteur a écrit:
Comment ajouter une image et un lien au forum?
Tu heberge ton image chez un hébergeur gratuit et tu colle le lien dans ton message !
Récupère le lien avec miniature chez ton hébergeur. Si tu en as pas il y a un bouton en haut pour heberger tes images !!
@++
Arrow

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Ven 14 Jan - 3:06

Salut pbrn,

Merci pour ta disponibilité

Les sources de Blender, tu crée un répertoire, par exemple : blender-svn, tu te mets dans ce répertoire et tu télécharge les sources.
Ensuite, sur ton PC, tu copie le répertoire blender-svn avec tout ce qu'il y a à l'intérieur sur ton disque dur !

Comment être dans un répertoire avec windows installé et me se mettre dans ce répertoire et téléchargé les sources ?
Je crois que généralement en téléchargeant avec un accélérateur ou pas on indique simplement le répertoire ou seront stockés ce qui sera téléchargé.

Je télécharge les librairies au paquetages .deb ou en sources dans les dépôts officiels sur packages.ubuntu.com

@+

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Ven 14 Jan - 10:07

serviteur a écrit:
Je crois que généralement en téléchargeant avec un accélérateur ou pas on indique simplement le répertoire ou seront stockés ce qui sera téléchargé.

Salut,
Heu ! Ta clé USB, c'est un disque !! elephant
Donc, il suffit que tu télécharge les fichiers sur ta clé et tu copie le répertoire des sources de la clé USB sur ton disque dur !
Si tu ne sais pas comment on fait, reprend le manuel de XP Surprised
ou cherche sur internet comment on fait ! study
@++
avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Mar 25 Jan - 18:17

Bonjour,
Une compilation de Blender 2.56 incluant le script d'export LuxRender pour Ubuntu 64 bits !

Vous devez quand même installer le moteur de rendu LuxRender 64 bits et configurer le répertoire ou se trouve le moteur LuxRender dans Blender 2.56 !
Archive Blender 2.56 avec le script LuxRender
Le 64 bits, ça "dépote" comme ont dit chez nous et LuxRender est plus performant !
Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Lun 28 Fév - 15:24

Salut,

Sur quels sites je peut télécharger sur un OS avec avec windows les sources pour la compilation de blender2.56a beta 32bits, car sur ubuntu le lien : svn co https://svn.blender.org/svnroot/bf-blender/trunk/blender
ne fonctionne qu'en console avec une connexion internet.

Cordialement

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Mar 1 Mar - 10:56

Salut,
Que ce soit avec n'importe quel OS (Linux, Mac, Windows...). Les sources se chargent par l'intermédiaire de la console à partir du SVN. Il faut absolument une connexion Internet .
Donc, connexion Internet et chargement des sources avec la console de l'OS.

Le le lien https://svn.blender.org/svnroot/bf-blender/trunk/blender/ marche sans problèmes ! Surprised
@++

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par serviteur le Mer 2 Mar - 5:47

Salut,

comment chargé des sources avec la console sur windows?

@+

serviteur

Messages : 130
Date d'inscription : 07/01/2011

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Mer 2 Mar - 10:15

Salut,
Ouvrir la console de Windows en cliquant sur Exécuter dans le menu, puis taper cmd dans le champ et valider !
Procéder de la même façon :
Créer un répertoire et dans ce répertoire (dans la console), svn co https://svn.blender.org/svnroot/bf-blender/trunk/blender
Après pour la compilation, c'est plus galère que sous Linux et il faut installer le compilateur VC !
Rolling Eyes

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Blender 2.56 est passé sous Python 3.2

Message par pbrn le Jeu 10 Mar - 12:44

Bonjour,
Pour ceux qui compilent Blender, la version 2.6-2 du SVN doit être compilée avec Python 3.2 !
C'est le tremplin pour la version 2.57 qui sera une version RC1 !
Si votre compilation habituelle échoue, ici la méthode à appliquer !
J'ai compilé Python 3.2, puis compilé Blender sous 64 bits avec un fichier user_config.py sous scons.
A titre personnel, j'ai aussi ajouté le script d'export pour LuxRender !
Compiler Blender 2.56 avec Python 3.2
ça avance à grands pas ! Cool

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par pbrn le Sam 6 Aoû - 15:44

Bonjour,
Une nouveauté depuis fin juillet 2011, il faut installer libspan-dev pour éviter l'erreur de compilation !
Voir Comment faire ici
@++

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2293
Date d'inscription : 22/04/2010
Age : 65
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: Comment compiler Blender 2.5 sur Ubuntu

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum