ubuntu 64 bits compiler blender

Voir le sujet précédent Voir le sujet suivant Aller en bas

ubuntu 64 bits compiler blender

Message par hudouriezh le Ven 29 Juil - 18:29

Bonjour,

(UBUNTU 64 bits, 2 coeurs)

Je viens de mettre au point l’installation UBUNTU, avec bien des soucis.
Mais bon avec persévérance et courage cela fonctionne à merveille.

Peut être devrais-je refaire une installation. J’ai une configuration qui me parait pas mal. Après un redémarrage, je me retrouve avec une autre configuration. Les fichiers se trouvent à gauche de l’écran. La première, j’avais la Liste en haut de l’écran et les deux écrans étaient identiques, ils fonctionnaient parfaitement.

La deuxième configuration, il a fallu que je bidouille pour arriver à faire fonctionner le deuxième écran. L’option « configurer les paramètres d'affichage » fonctionnaient avec la première version, mais pas avec la deuxième.

Enfin voilà mes aventures Ubuntu. (je pense que c’est ubuntu 11.4 (Natty Narwahal)) si j’ai bien compris la leçon !

Je me suis amusé toute la semaine à comprendre comment cela fonctionne bien qu’il y a des points noirs qui reste dans le noir.........

Maintenant je suis rendu sur la compilation de Blender 64. J’ai suivit votre tutoriel «blender-4d: Tutoriel compilation Blender 2.5 pour 64 bits » , impeccable en explications et fichiers. Mais évidement il y a un problème... « pas de votre coté rassurez-vous », arrivé à la fin voilà ce qui s’affiche :

Command-line arguments

No command-line arguments given

Command-line targets

No targets given, using default

Using config file: build_files/scons/config/linux2-config.py

user-config.py not found, no user overrides

Build with parallel jobs: 2

Build with debug symbols: False



Missing: "/usr/include/python3.2m/Python.h",

Set 'BF_PYTHON_INC' to point to a valid python include path.

Containing Python.h for python version "3.2"

XXXXXX@XXXXXXX-System-Product-Name:~/blender-svn/blender$

Je crois comprendre qu’il faut mettre à jour python 3.2 ce que j’ai fait mais rien ne se passe. Vérification du fichier Blend SVN, il y est bien.

J'ai même essayer d'installer votre compile « le fichier Tarball de ma compilation du 23/03/2011 pour Maverick Meerkat » le lien est mort mais c'est Free..............

Enfin pas trop doué...............

Auriez-vous une explication car là je patauge.

Merci d’avance. A+
[table]
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Ven 29 Juil - 22:54

Bonsoir,
Un petit peu de temps d'adaptation entre Windoz et Linux, mais vous ne le regretterez pas ! Il faut simplement changer ses habitudes et Linux (Ubuntu est plus facile que Windoz et surtout plus puissant) Cool

Pour votre problème !
Quelle commande avez vous tapé ?
Normalement sous la 11.04, il n'y a pas besoin d'installer Python 3.2 puisque maintenant il est inclus !
Quel User_config.py utilisez vous ?
A mon avis, vous n'utilisez pas le bon user_config.py.
Si vous voulez résoudre votre problème, je vous invite à visionner
le fil de discussion, puisque gillouni a rencontré le même problème que vous !
Créez donc un fichier user_config.py que vous placez dans le répertoir Blender des fichiers du SVN, puis relancez la compilation.
Quand on compile un pogramme comme Blender, il y a un fichier général qui pilote la compilation, mais souvent on est obligé de créer un fichier user_config.py pour adapter.
Le fichier user_config.py du fil de discussion est adapté à la compilation de Blender sous Ubuntu 11.04.

Si vous avez des problèmes, dites-moi ce que vous tapez et quel fichier user_config.py vous utilisez ?
Normalement, si vous appliquez ce qui est dit à la fin du fil de discussion, vous ne devriez pas avoir de problèmes !
N'oubliez pas qu'un ordinateur n'est capable de faire que ce que l'on lui dit clairement !! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Sam 30 Juil - 16:48

Bonjour,
je reprends le fil de la discussion, petits enfants oblige.

j'utilise le user-config.py je crois bien avoir le même, que voici :

BF_PYTHON_VERSION = '3.2'
SUFFIX = "mu" # may be any combination of 'dmu'
BF_PYTHON_INC = '${BF_PYTHON}/include/python${BF_PYTHON_VERSION}' + SUFFIX
BF_PYTHON_LIB = 'python${BF_PYTHON_VERSION}' + SUFFIX

je viens de faire la commande python...... j'obtiens :

Python 2.7.1+ (r271:86832, Apr 11 2011, 18:13:53)
[GCC 4.5.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> BF_PYTHON_VERSION = '3.2'
>>> SUFFIX = "mu" # may be any combination of 'dmu'
>>> BF_PYTHON_INC = '${BF_PYTHON}/include/python${BF_PYTHON_VERSION}' + SUFFIX
>>> BF_PYTHON_LIB = 'python${BF_PYTHON_VERSION}' + SUFFIX

là je ne vois pas trop quoi faire.................


je pensais avoir installer python 3.2, cela n'a pas eu lieu.

en plus je me mélange les crayons.............
Sad
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Sam 30 Juil - 16:58

je viens d’essayer ceci sujet de fil de la discussion :

hudouriezh@hudouriezh-System-Product-Name:~$ sudo apt-get install subversion build-essential gettext \
> libxi-dev libsndfile1-dev \
> libpng12-dev libfftw3-dev \
> libopenexr-dev libopenjpeg-dev \
> libopenal-dev libalut-dev libvorbis-dev \
> libglu1-mesa-dev libsdl1.2-dev libfreetype6-dev \
> libtiff4-dev libsamplerate0-dev libavdevice-dev \
> libavformat-dev libavutil-dev libavcodec-dev libjack-dev \
> libswscale-dev libx264-dev libmp3lame-dev python3.2-dev sudo apt-get install libpython3.2 libopenal1 libfftw3-3 libilmbase6 libopenexr6 libavformat52 libavdevice52 libswscale0
[sudo] password for hudouriezh:
Sorry, try again.
[sudo] password for hudouriezh:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet apt-get
E: Impossible de trouver le paquet install
hudouriezh@hudouriezh-System-Product-Name:~$
Shocked
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Sam 30 Juil - 19:05

Bonsoir,
Je suis vraiment une tête de mule.
Le fichier user.config était mal placé.
je l'ai mis dans blender-svn au lieu de blender-svn --> blender.
voilà j'ai enfin blender.
J'ai quand même un petit problème. blender s'affiche sur mes deux écrans je vais essayer de régler cela.

Merci, PBRN pour votre disponibilité, votre travail sérieux et votre contact humain, tout ça pour un service vraiment personnel. c'est rare à notre époque.
A + Very Happy
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Sam 6 Aoû - 15:15

Bonjour,
Pour ceux qui compilent Blender à partir du SVN
Depuis quelques jours, Il faut installer libspnav pour éviter d'avoir l'erreur !
Comment installer cette librairie ?
Comme d'habitude en faisant :
Code:
sudo apt-get install libspanv-dev
Puis Return !
Relancez la compilation de Blender et c'est bon !
Si vous avez des problèmes, posez vos questions ici.
@++

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Sam 3 Sep - 8:04

bonjour,
je viens de faire une mise à jour SVN Blender. révision 39885
comme d'habitude j'ai une erreur.
faut-il rajouter un sudo confused
Merci.

@+
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Sam 3 Sep - 10:46

Bonjour,
Il ne faut pas compiler en sudo ! Evil or Very Mad

L'erreur que tu as est normale !
Sous Ubuntu 11.04, la FFMPEG n'est plus à jour.
Trois solutions possibles

  1. Soit installer un ppa
  2. Soit attendre la version de Ubuntu 11.10 qui va bientôt sortir
  3. Soit désactiver FFMPEG en ajoutant cette ligne ci dessous dans l' user_config.py

Code:
WITH_BF_FFMPEG = 'false'
Attention à bien respecter les espaces et syntaxe

Quand la 2.6 sera sortie, il y aura moins de changements !
Si tu veux installer un ppa, je peux te dire comment faire, mais ça sera dur. Wink
Attend patiemment et à partir de 2.6 tu pourras reprendre les compilation et ce sera plus abordable ! Cool

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Sam 3 Sep - 17:05

Bonjour pbrn,

Tu parle de désactivation FFMPEG, c'est le module ce trouvant dans le blend SVN --> blender :

Code:

BF_PYTHON_VERSION = '3.2'
SUFFIX = "mu" # may be any combination of 'dmu'
BF_PYTHON_INC = '${BF_PYTHON}/include/python${BF_PYTHON_VERSION}' + SUFFIX
BF_PYTHON_LIB = 'python${BF_PYTHON_VERSION}' + SUFFIX

Si c'est cela je le place entre quelle ligne ....

Pour ce qui est de l'installation d'un PPa j'aimerais bien comprendre la ta-tic à suivre. Je suis un peut têtu. j'aime pas trop qu'une machine me face des siennes, je préfère en faire.
je ne voudrais pas trop abuser de votre temps, je suis prêt à faire l'aventure.

avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Lun 5 Sep - 12:07

Salut,
Comme ceci à la suite :
Code:
BF_PYTHON_VERSION = '3.2'
SUFFIX = "mu" # may be any combination of 'dmu'
BF_PYTHON_INC = '${BF_PYTHON}/include/python${BF_PYTHON_VERSION}' + SUFFIX
BF_PYTHON_LIB = 'python${BF_PYTHON_VERSION}' + SUFFIX
WITH_BF_FFMPEG = 'false'

Pour les ppa, ce sont des dépôts de paquets personnels qu'il faut installer à la ligne de commande.
Un lien ci-dessous qui facilite la tâche :
PPA
Par contre, il faut faire attention à ce que l'on fait ! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Lun 5 Sep - 16:11

Salut,
Tout va bien, la machine est remise à l’endroit.
La petite ligne ajouter est efficace.
J’étudie la question des ppa.
Je vous tiens au courant des dérapages...................

@+ Very Happy

avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Lun 5 Sep - 17:40

salut,
C'est provisoire, en attendant que la nouvelle FFMpeg soit disponibe dans la prochaine version de Ubuntu.
Donc, à ce moment là, il faudra supprimer cette ligne dans le user_config.py puisque elle empêche l'utilisation de FFMpeg, de même si on installe un ppa.

En attendant, il faut soit récupérer le code source et la compiler, soit en récupérer une déjà compilée dans un ppa
Tu peux installer Y-PPA qui se trouve dans le Synaptic en faisant une reherche sur son nom ; Y-PPA
Y-PPA permet de chercher, installer et désinstaller un ppa plus facilement.
@++ Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Mar 27 Déc - 11:59

Bonjour,
A propos de disque dur. Aurais-tu une astuce pour récupérer les fichiers Blend.
Un Logiciel à télécharger.
Le disque à simplement été effacé.
Je ne l'ai pas partitionné, ni formaté.
Il y à peut être un espoir.

@+
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Mar 27 Déc - 12:16

Bonjour,
Il y a des logiciels qui permettent de récupérer des fichiers effacés !
Quand un fichier est effacé, il y a juste l'adresse de la table d'allocation. Tantt que tu ne fais pas un formatage de bas niveau ou là il faut acquérir les softs du FBI !!

Maintenant, si tu n'as rien effacé, c'est peut être grave !!

Normalement, avec Ubuntu, tu peux reconstituer des partitions. Mais moi à mon avis si ton disque fonctionne toujours, tu as du faire une fausse manip !

Quelques logiciels de récupération de données

Ce que je te conseillerai quand même, c'est de faire des sauvegardes, chaque fois que tu as fait un travail important. Un disque peut toujours lâcher et la sauvegarde c'est vital !
Moi, j'utilise Areca pour faire mes sauvegardes ! Sleep

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par hudouriezh le Mar 27 Déc - 15:53

salut,
Merci pour l'info. je n'ai plus que les yeux pour pleurer.
C'est un disque dur externe, je l'avais laissé branché pendant la remise à niveau UBUNTU. qui me servais de sauvegarde erreur de manip................
J'ai essayé plusieurs logiciel. j'ai bien récupérer les photos certain fichier vidéo.
Pour ce qui est des fichiers blend. pas moyen.
Même pas les word doc, docx etc...............
Bon ben......................tant pis pour les archives.
No

@+
avatar
hudouriezh

Messages : 337
Date d'inscription : 18/12/2010
Age : 67
Localisation : cote d'azur

http://hudouriezh-3d.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par pbrn le Mar 27 Déc - 17:34

Dommage ! Rolling Eyes
Alors, fait des sauvegardes incrémentielles !! Wink

_________________

                                                                                                                                     


avatar
pbrn
Admin

Messages : 2285
Date d'inscription : 22/04/2010
Age : 64
Localisation : Cognac

http://pbrn.blogspot.com/

Revenir en haut Aller en bas

Re: ubuntu 64 bits compiler blender

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum